gmime-2.2.27 dependencia para Dbmail 2.2.17
This commit is contained in:
parent
6d8b907a2d
commit
39d592d49e
3 changed files with 109 additions and 0 deletions
4
dev-libs/gmime/Manifest
Normal file
4
dev-libs/gmime/Manifest
Normal file
|
@ -0,0 +1,4 @@
|
|||
AUX gmime-2.2.23-sign-assembly.patch 1380 SHA256 086c23ebb3b7c5f8e1e2133ab41fea623947cbbc790af25efb8e3d2e64111a8f SHA512 b7a666efbdc665fa639238a71816032de5cbb450cdd393ffc07ca03a1f3c254271d07dbc2314cb733564455af9bed5e44af86e0e4ed631c545f37cbc25ab20af WHIRLPOOL b61ca9f342e22d8a05072a6807b1ae6fc57c9e6a11bcc20c03e8c952af43646fbbffaea07612c9338953ebb8a64793327336331b55c7b06a4b19eabf6c889206
|
||||
DIST gmime-2.2.27.tar.bz2 790878 SHA256 73b0ffb5c6cfb8614a5fb0d3a9fd75856d65905be39133baf1dd12efe51f24eb SHA512 bc648c219f17d89af150cf040c70553ae7cffce94710da0d6403fb4d35c8f2801ddfcee6a59d074dd379259cdc7d7375ea9a2bf888eb655278135b84cf4fc1e2 WHIRLPOOL 024deac8ed37173c1097591e12669d99b0541186e8141436868e58ec791eb923bc87371b7af37c8c873b258f67affa86fe781a0ac815c3c8d1cbd94d4457b68f
|
||||
DIST gmime-sharp.snk 596 SHA256 f71eb61399bb038acc847298b74eee6c03a8773309dc5c10929ee4aa0aeb3948 SHA512 aa5c9aa99e07008e1f6551b8dfca289bfd9eb8ace21cb605951adbde699579820851544f8c22c2ce7f478a8854645bebf746b0475322eaa24b74746bc207da0e WHIRLPOOL 5ae3ed48788e09763d5274c0909c42f750ee3fb84eee9166adafc016acc20dbed81e3b1066cc4eafffc1967034b197606764450495dcde89230d7453c2165680
|
||||
EBUILD gmime-2.2.27.ebuild 2219 SHA256 84590ce22015c12b5087ee5f7f27a45eb37492ad7eb1fad405cda6b895832d66 SHA512 67d83656cd2dc3733f0d090bb510bf6968b21268eeb81ca875f2efc204673930763541e122da0c2d0e8df2154ef9555ec0d5d6bfb0b94ea5eae5c3f995eacc62 WHIRLPOOL 7b5f05d7dbaaa215eb946421d53eced0bef9842dafe6be9ec623c93baa7347207e7bf70b60b79542e19a2468fa9c2c1465d2f3e4abfcad1fcf4061a04566a16c
|
26
dev-libs/gmime/files/gmime-2.2.23-sign-assembly.patch
Normal file
26
dev-libs/gmime/files/gmime-2.2.23-sign-assembly.patch
Normal file
|
@ -0,0 +1,26 @@
|
|||
diff -NrU5 gmime-2.2.23.orig/mono/AssemblyInfo.cs.in gmime-2.2.23/mono/AssemblyInfo.cs.in
|
||||
--- gmime-2.2.23.orig/mono/AssemblyInfo.cs.in 2009-01-25 19:01:15.000000000 +0100
|
||||
+++ gmime-2.2.23/mono/AssemblyInfo.cs.in 2009-01-25 19:02:08.000000000 +0100
|
||||
@@ -1,6 +1,4 @@
|
||||
using System.Reflection;
|
||||
using System.Runtime.CompilerServices;
|
||||
|
||||
[assembly:AssemblyVersion("@API_VERSION@")]
|
||||
-[assembly:AssemblyDelaySign(true)]
|
||||
-[assembly:AssemblyKeyFile("@srcdir@/gmime-sharp.pub")]
|
||||
diff -NrU5 gmime-2.2.23.orig/mono/Makefile.am gmime-2.2.23/mono/Makefile.am
|
||||
--- gmime-2.2.23.orig/mono/Makefile.am 2009-01-25 19:01:35.000000000 +0100
|
||||
+++ gmime-2.2.23/mono/Makefile.am 2009-01-25 18:57:11.000000000 +0100
|
||||
@@ -72,11 +72,11 @@
|
||||
rm -f generated/* && \
|
||||
$(GAPI_CODEGEN) --generate $(API) --outdir=generated --customdir=$(srcdir) --assembly-name=$(ASSEMBLY_NAME) \
|
||||
&& touch generated-stamp
|
||||
|
||||
$(ASSEMBLY): $(build_sources) generated-stamp $(ASSEMBLY_NAME).pub
|
||||
- $(CSC) --unsafe /out:$(ASSEMBLY) /target:library $(references) $(build_sources) generated/*.cs
|
||||
+ $(CSC) --unsafe /out:$(ASSEMBLY) -keyfile:$(ASSEMBLY_NAME).snk /target:library $(references) $(build_sources) generated/*.cs
|
||||
|
||||
install-data-local:
|
||||
@if test -n '$(TARGET)'; then \
|
||||
if test -n '$(DESTDIR)'; then \
|
||||
echo "$(GACUTIL) /i $(ASSEMBLY) /f /package $(PACKAGE_SHARP) /root $(DESTDIR)$(prefix)/lib"; \
|
79
dev-libs/gmime/gmime-2.2.27.ebuild
Normal file
79
dev-libs/gmime/gmime-2.2.27.ebuild
Normal file
|
@ -0,0 +1,79 @@
|
|||
# Copyright 1999-2011 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmime/gmime-2.2.27.ebuild,v 1.9 2011/10/05 16:53:02 xarthisius Exp $
|
||||
|
||||
EAPI="4"
|
||||
GNOME_TARBALL_SUFFIX="bz2"
|
||||
GCONF_DEBUG="no"
|
||||
|
||||
inherit gnome2 eutils mono libtool autotools
|
||||
|
||||
DESCRIPTION="Utilities for creating and parsing messages using MIME"
|
||||
HOMEPAGE="http://spruce.sourceforge.net/gmime/"
|
||||
|
||||
SRC_URI="${SRC_URI} http://dev.gentoo.org/~pacho/gnome/gmime-sharp.snk"
|
||||
|
||||
SLOT="0"
|
||||
LICENSE="LGPL-2.1"
|
||||
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
|
||||
IUSE="doc mono"
|
||||
|
||||
RDEPEND=">=dev-libs/glib-2:2
|
||||
sys-libs/zlib
|
||||
mono? (
|
||||
dev-lang/mono
|
||||
>=dev-dotnet/gtk-sharp-2.4.0:2 )"
|
||||
DEPEND="${RDEPEND}
|
||||
dev-util/pkgconfig
|
||||
dev-util/gtk-doc-am
|
||||
doc? (
|
||||
>=dev-util/gtk-doc-1.0
|
||||
app-text/docbook-sgml-utils )
|
||||
mono? ( dev-dotnet/gtk-sharp-gapi:2 )"
|
||||
|
||||
pkg_setup() {
|
||||
DOCS="AUTHORS ChangeLog COPYING INSTALL NEWS PORTING README TODO doc/html/"
|
||||
G2CONF="${G2CONF} $(use_enable mono)"
|
||||
}
|
||||
|
||||
src_prepare() {
|
||||
epatch "${FILESDIR}/gmime-2.2.23-sign-assembly.patch"
|
||||
|
||||
cp "${DISTDIR}/gmime-sharp.snk" mono/ || die
|
||||
if use doc ; then
|
||||
#db2html should be docbook2html
|
||||
sed -i -e 's:db2html:docbook2html -o gmime-tut:g' \
|
||||
docs/tutorial/Makefile.am docs/tutorial/Makefile.in \
|
||||
|| die "sed failed (1)"
|
||||
sed -i -e 's:db2html:docbook2html:g' configure.in configure \
|
||||
|| die "sed failed (2)"
|
||||
# Fix doc targets (bug #97154)
|
||||
sed -i -e 's!\<\(tmpl-build.stamp\): !\1 $(srcdir)/tmpl/*.sgml: !' \
|
||||
gtk-doc.make docs/reference/Makefile.in || die "sed failed (3)"
|
||||
fi
|
||||
|
||||
eautoreconf
|
||||
elibtoolize
|
||||
}
|
||||
|
||||
src_compile() {
|
||||
MONO_PATH="${S}" emake
|
||||
# 'all' rule doesn't generate html files
|
||||
use doc && cd docs/tutorial/ && emake html
|
||||
}
|
||||
|
||||
src_install() {
|
||||
emake DESTDIR="${D}" install
|
||||
|
||||
if use doc ; then
|
||||
# we don't use docinto/dodoc, because we don't want html doc gzipped
|
||||
insinto /usr/share/doc/${PF}/tutorial
|
||||
doins docs/tutorial/html/*
|
||||
fi
|
||||
|
||||
# rename these two, so they don't conflict with app-arch/sharutils
|
||||
# (bug #70392) Ticho, 2004-11-10
|
||||
mv "${ED}/usr/bin/uuencode" "${ED}/usr/bin/gmime-uuencode"
|
||||
mv "${ED}/usr/bin/uudecode" "${ED}/usr/bin/gmime-uudecode"
|
||||
mono_multilib_comply
|
||||
}
|
Loading…
Reference in a new issue