sys-block/open-isns: Removed old ebuild, incompatible with EAPI 6
This commit is contained in:
parent
f8bc64bc28
commit
78cdb94366
3 changed files with 0 additions and 56 deletions
|
@ -1,3 +0,0 @@
|
||||||
AUX libressl.patch 420 BLAKE2B 4523f1c32e6db8274392e98eb224d91b8a90e9babeded9c6e342f2635dd6ab0c64b2e6778d05edf5e54d7c7289365d0a590d509682eb5865fa4a6450c076861d SHA512 3a01a78c19114801ce4d80568eca158615f338a27133eb7639258ebb9114afa66cbbf0c0d871f00b7e85a4903f1c2444866daaccc3e3b187d0d4d47d7e86adc2
|
|
||||||
DIST open-isns-0.98.tar.gz 278410 BLAKE2B f90df85de4d5fd2abdcd267e3c873dff62fcac523ee280e21def057eca366bbba21c2b3bfbf5cc0798b8d0f3b0d5028ebb49000cccc850abdfb85142a7b66c34 SHA512 04263b9ace9d272f4e3776c4e1a034815475590d4b4864217a6200fcd5baea391cd788723db3c17fe0d764efc9769a70a3d2167b00e5998fb4bcb8d5fe2547ed
|
|
||||||
EBUILD open-isns-0.98-r1.ebuild 941 BLAKE2B 75103da7e00faf8d339564086d7b0671b0d8bc7e2ef62ca688842411445e387ca3a62fa5b557b728069c96fee9a606b1684b481c5a98ec33ccc2785003c049dd SHA512 435a343a5fe254c6b9cfd50fc667ec6e1c5f12b5a254dd45b74a4b32730f827c5d2ec18e44dca00bee59ee91f32e4b968169eb1dc1792a14dac4d6f326291478
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- a/pki.c.orig
|
|
||||||
+++ b/pki.c
|
|
||||||
@@ -30,7 +30,7 @@
|
|
||||||
#endif
|
|
||||||
/* OpenSSL 1.1 made a lot of structures opaque, so we need to
|
|
||||||
* define the 1.1 wrappers in previous versions. */
|
|
||||||
-#if OPENSSL_VERSION_NUMBER < 0x10100000L
|
|
||||||
+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
|
|
||||||
#define EVP_PKEY_base_id(o) ((o)->type)
|
|
||||||
#define EVP_PKEY_get0_DSA(o) ((o)->pkey.dsa)
|
|
||||||
static EVP_MD_CTX *EVP_MD_CTX_new(void)
|
|
|
@ -1,42 +0,0 @@
|
||||||
# Copyright 1999-2017 Gentoo Foundation
|
|
||||||
# Distributed under the terms of the GNU General Public License v2
|
|
||||||
|
|
||||||
EAPI=6
|
|
||||||
|
|
||||||
inherit flag-o-matic
|
|
||||||
|
|
||||||
DESCRIPTION="iSNS server and client for Linux"
|
|
||||||
HOMEPAGE="https://github.com/open-iscsi/open-isns"
|
|
||||||
SRC_URI="https://github.com/open-iscsi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
|
|
||||||
|
|
||||||
LICENSE="LGPL-2.1"
|
|
||||||
SLOT="0"
|
|
||||||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
|
|
||||||
IUSE="debug slp ssl static libressl"
|
|
||||||
|
|
||||||
DEPEND="
|
|
||||||
ssl? (
|
|
||||||
!libressl? ( dev-libs/openssl:0= )
|
|
||||||
libressl? ( dev-libs/libressl:0= )
|
|
||||||
)
|
|
||||||
slp? ( net-libs/openslp )"
|
|
||||||
RDEPEND="${DEPEND}"
|
|
||||||
|
|
||||||
PATCHES=()
|
|
||||||
|
|
||||||
src_configure() {
|
|
||||||
use debug && append-cppflags -DDEBUG_TCP -DDEBUG_SCSI
|
|
||||||
append-lfs-flags
|
|
||||||
epatch "${FILESDIR}"/libressl.patch
|
|
||||||
|
|
||||||
econf $(use_with slp) \
|
|
||||||
$(use_with ssl security) \
|
|
||||||
$(use_enable !static shared)
|
|
||||||
}
|
|
||||||
|
|
||||||
src_install() {
|
|
||||||
default
|
|
||||||
emake DESTDIR="${D}" install_hdrs
|
|
||||||
emake DESTDIR="${D}" install_lib
|
|
||||||
}
|
|
||||||
|
|
Loading…
Reference in a new issue