Resolved in https://bugs.gentoo.org/741544
This commit is contained in:
parent
20d03305c4
commit
8030802146
4 changed files with 0 additions and 128 deletions
|
@ -1,4 +0,0 @@
|
|||
AUX tomsfastmath-0.13.1-makefile-fix.patch 1703 BLAKE2B 2182f88b8569fac105eb179fdc7c10a7c9b7b17619a725c30d8374a2589f048e0ca0fe71ffb2431e058a264b104bc091deb800215a490399e722055b39adee0e SHA512 f5e5df821ecc7beb8684116294322dae8bf166bfbc7cf3d5262534e036f1d486854e58ad2c2da382b8f08aa6b9db71d91607289587c4247837bdfc3313ad5cff
|
||||
DIST tfm-0.13.1.tar.xz 322684 BLAKE2B 393c0e0e018b199c9fc975ab3013466399ea337f520f4634649a9e61b2218b9a6b218d11212b535fc8bbd2bf40d8722fc413dc60756f1b8ff7c78da049765083 SHA512 84225fe81bbcd1df7e40ed0b8c8077d60612246a76f3149b672dfd1066eb0179262fa4f5a42ffd2034e60cb74cfd86e0b49139371971ebbb4f41a4ecebca2111
|
||||
EBUILD tomsfastmath-0.13.1.ebuild 1630 BLAKE2B d08134833c2a328f2a602b7a5346b46e9277d9e6b2c637a062f21deac94b54e83ee70654ac7ae70d42ab237844e257c8fb8faebc347ddf7a78834f7d3b6cb946 SHA512 b24ef210f27e042466800e240c97f6916ca346d7f6b6802bfa9bd47a8a15b6e132a5dbacef82ec8f3dd7308ad1c4b184bba4a16e5db0c4da6663fd77faedc72a
|
||||
MISC metadata.xml 358 BLAKE2B 8dc827f40c0b51ca769622a56b5282b3265428fccc2330cb1732faa1ab03a6962057eccda6c0c0b58bfed3fa190e64c77fad4e6480cf65fe7ee251eb087422e8 SHA512 1473c76d0d4a743815de12895599cb3f9f97201f0eca1231af0f16600b5b795dcd8c4cba4847e3166004dc0b3319011bba2945dda510bd789d7b0ee066d96f88
|
|
@ -1,45 +0,0 @@
|
|||
diff --git a/makefile.shared b/makefile.shared
|
||||
index 47c35d9..cebaa04 100644
|
||||
--- a/makefile.shared
|
||||
+++ b/makefile.shared
|
||||
@@ -1,7 +1,8 @@
|
||||
#makefile for TomsFastMath
|
||||
#
|
||||
#
|
||||
-VERSION=1:0:0
|
||||
+VERSION=0.13.1
|
||||
+VERSION_LIB=1:0:0
|
||||
|
||||
LT ?= libtool
|
||||
LTCOMPILE = $(LT) --mode=compile --tag=CC $(CC)
|
||||
@@ -89,13 +90,16 @@ $(OBJECTS): $(HEADERS)
|
||||
$(LTCOMPILE) $(CFLAGS) $(LDFLAGS) -o $@ -c $<
|
||||
|
||||
$(LIBNAME): $(OBJECTS)
|
||||
- libtool --mode=link --tag=CC $(CC) $(CFLAGS) $(LDFLAGS) `find . -type f | LC_ALL=C sort | grep "[.]lo" | xargs` -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION) -export-symbols libtfm.symbols
|
||||
+ libtool --mode=link --tag=CC $(CC) $(CFLAGS) $(LDFLAGS) `find . -type f | LC_ALL=C sort | grep "[.]lo" | xargs` -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION_LIB) -export-symbols libtfm.symbols
|
||||
|
||||
install: $(LIBNAME)
|
||||
install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(LIBPATH)
|
||||
libtool --mode=install install -c $(LIBNAME) $(DESTDIR)$(LIBPATH)/$(LIBNAME)
|
||||
install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(INCPATH)
|
||||
install -g $(GROUP) -o $(USER) $(HEADERS_PUB) $(DESTDIR)$(INCPATH)
|
||||
+ sed -e 's,^Version:.*,Version: $(VERSION),' tomsfastmath.pc.in > tomsfastmath.pc
|
||||
+ install -d $(DESTDIR)$(LIBPATH)/pkgconfig
|
||||
+ install -m 644 tomsfastmath.pc $(DESTDIR)$(LIBPATH)/pkgconfig/
|
||||
|
||||
HEADER_FILES=$(notdir $(HEADERS_PUB))
|
||||
uninstall:
|
||||
diff --git a/tomsfastmath.pc.in b/tomsfastmath.pc.in
|
||||
new file mode 100644
|
||||
index 0000000..a0275ab
|
||||
--- /dev/null
|
||||
+++ b/tomsfastmath.pc.in
|
||||
@@ -0,0 +1,7 @@
|
||||
+# TomsFastMath, a fast ISO C bignum library. -- Tom St Denis
|
||||
+# SPDX-License-Identifier: Unlicense
|
||||
+
|
||||
+Name: TomFastMath
|
||||
+Description: Fast multiple-precision integer library
|
||||
+Version: @VERSION@
|
||||
+Libs: -ltfm
|
|
@ -1,12 +0,0 @@
|
|||
<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
|
||||
<pkgmetadata>
|
||||
<maintainer type="person">
|
||||
<email>sam@gentoo.org</email>
|
||||
<name>Sam James</name>
|
||||
</maintainer>
|
||||
<maintainer type="person">
|
||||
<email>mjo@gentoo.org</email>
|
||||
<name>Michael Orlitzky</name>
|
||||
</maintainer>
|
||||
</pkgmetadata>
|
|
@ -1,67 +0,0 @@
|
|||
# Copyright 1999-2020 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=7
|
||||
|
||||
inherit toolchain-funcs
|
||||
|
||||
DESCRIPTION="Fast public domain large integer arithmetic library"
|
||||
HOMEPAGE="https://www.libtom.net/TomsFastMath/
|
||||
https://github.com/libtom/tomsfastmath"
|
||||
SRC_URI="https://github.com/libtom/tomsfastmath/releases/download/v${PV}/tfm-${PV}.tar.xz"
|
||||
LICENSE="Unlicense"
|
||||
|
||||
# Current SONAME is 1
|
||||
# Please bump when the ABI changes upstream
|
||||
# Helpful site:
|
||||
# https://abi-laboratory.pro/index.php?view=timeline&l=tomsfastmath
|
||||
SLOT="0/1"
|
||||
|
||||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}/${P}-makefile-fix.patch"
|
||||
)
|
||||
|
||||
_emake() {
|
||||
# Standard boilerplate
|
||||
# Upstream use homebrewed makefiles
|
||||
# Best to use same args for all, for consistency,
|
||||
# in case behaviour changes (v possible).
|
||||
emake \
|
||||
CC="$(tc-getCC)" \
|
||||
AR="$(tc-getAR)" \
|
||||
RANLIB="$(tc-getRANLIB)" \
|
||||
DESTDIR="${ED}" \
|
||||
LIBPATH="/usr/$(get_libdir)" \
|
||||
"$@"
|
||||
}
|
||||
|
||||
src_compile() {
|
||||
_emake -f makefile.shared
|
||||
}
|
||||
|
||||
src_test() {
|
||||
_emake test_standalone stest rsatest
|
||||
|
||||
# We choose to be verbose during the test process
|
||||
# because the output is quite repetitive with no
|
||||
# clear demarcation b/t tests
|
||||
local tests=( "test" "stest" "rsatest" )
|
||||
|
||||
local test
|
||||
for test in "${tests[@]}"; do
|
||||
einfo "Running test (${test})"
|
||||
./${test} || die "Test (${test}) failed"
|
||||
einfo "Completed test (${test})"
|
||||
done
|
||||
}
|
||||
|
||||
src_install() {
|
||||
_emake -f makefile.shared install
|
||||
|
||||
# Remove unnecessary .la files
|
||||
find "${ED}" -name '*.la' -delete || die
|
||||
# Same for static libs
|
||||
find "${ED}" -name "*.a" -delete || die
|
||||
}
|
Loading…
Reference in a new issue