gnome-base/gnome-vfs: EAPI 8 and preserved dependencies

This commit is contained in:
Sandino Araico Sanchez 2023-09-05 05:32:35 -06:00
parent ccf7938e6a
commit e8b9ed625c
14 changed files with 579 additions and 3 deletions

View file

@ -0,0 +1,9 @@
AUX gconf-2.24.0-no-gconfd.patch 787 BLAKE2B d37a7b8c4833ba32406dea408e6c1ab65687ca9ecd6743ccdc0375432d569c4cd9b02e3011cd340f72ce2eae683381f58744cbabf556bd259216f9f3807ab9b7 SHA512 c7f7437321d2afcbe75a8b8d819f04e5864cde3b2130f6dcff78c622b9bd336c66a30d666e0a4283d2fcf5c54afc741cc84f90401889127b03ef22b0752fb7b8
AUX gconf-2.28.0-entry-set-value-sigsegv.patch 533 BLAKE2B 004abc644ba4ef6f839ba6179152d2de7d3b709aff8aca37609c1da5d2fa6fb20c54faad0895d5bcb972c8826a58743c01a87ccf54c450fe1734f81219a9c126 SHA512 c0576004aa8c8b64750037183a5d3df5b4d8ba520c83f33a906a8549139e2167d08c1bcc56cbdfe202bb078a703bd561680af63588f7ee4eb42ad6077182a3fa
AUX gconf-3.2.6-gsettings-data-convert-paths.patch 1370 BLAKE2B 9fdb3c665c8515cace2325479735fec4b024adea8f2ab1fb89e76ef594eeebda897a3d3f52c8e7c48a21d03e2097211d90ed45887c6542ca6cc93a22ae8e6a15 SHA512 f4d7cc2261f82f7a28e574ec3b732a56bb3f067048312e318f8d23df93046489fdd5ad39d669cf0d9ada6cc07617524511c537a4f2fd0a37cd03788e84b9803b
AUX gconf-3.2.6-mconvert-crasher.patch 1514 BLAKE2B 3e48d07777268faa3a1c98f168d33baded66df06185e8e1c77ae8f66f0c689c5a358018d1d3c060e5a4796c3f692acf346141db87f3cb6784ddabbe461432a69 SHA512 8b6885098b63077610b929c3b958efc04599a1f891a0d7b5f042f2638dbae7b3c67b97e7f4e34c439e55ff8c5df3bcc7c6edc56f11cd6506a4b28c2338c8511b
AUX gconf-3.2.6-python3.patch 6699 BLAKE2B 20e24d3f55ccc3455a62fd72fcb054c6fd33308bda419f21426417dd4f9a79581cc5cd03449bad9063e4e927875ed020a99254609517b3c86ebb1b65f268d3d2 SHA512 def5cd74ec7b9d06dc1ccd05364bfa500f8d9685ea3016f219c53df925b09f68dfaf547277dd0dfb9eed266be4de650875611a09a84bc0db3d0a7b907c7beb73
AUX gconf-3.2.6-spew-console-error.patch 2594 BLAKE2B 6a6f27024289b1c578f6718c184e7604f0f1dc285ea58a8095fac06f5fa38273329c8b2535b4de8c17c8359f09f82aa474fa5ebcef739b0e2dd6e7d6fb7726d7 SHA512 abdddbcab24d80870691a45cdf8d4baa7021f363efa26ba140221afef0bd96756b7234fb1d61ea46c4d137854f59d2589f2e1f1d125fdcb1fad3acf9215a8602
DIST GConf-3.2.6.tar.xz 1559904 BLAKE2B dc71bfc6e334b0a3545b6009fc1a592f3ba6adb1471aacc98aaa1ded9e89676f97415c26a3d17e297a846a7efca7ee695107c136ea28b2431f90dc966a3d64cc SHA512 35f5f659f9d03f7531a7102adacbda0eb310d8a55a831c768c91a82e07dae21247726e00e0e411f63b1de9ade0f042ded572a3ea4a4b2ad3135231f344540b58
EBUILD gconf-3.2.6-r6.ebuild 3823 BLAKE2B d6b675b31731f93832dabf0a9ba9a300eaa7299da4347b7a7cde7cb7ba33f2b2e6e021d97fa321eefde2e975853e23a9d31503544be95243de64d869ddb3f1c4 SHA512 56a5af6f9d9fa52398a2e5f6428a0cbbdc3916ec86b1bd08159f98bb52dfa44d485b7fe4a230eaa0bf74df96aeb2d8319a117009b036ee46fde15a2eb72c97f4
MISC metadata.xml 534 BLAKE2B ddae4d5cfa2efb408657c89654c7d8271fb67f01ea97b7d0ed2e55ceb8cee1dce02e3c41b691e955cd06eff578af3c73563cc808fb3bcdc7d1d093ab81508057 SHA512 9e76fb685bf27be1439ad6838bd046bf6e9cd78e5a6ca471172d6024108e9d7a4f7bac66136436547bdc1ae54636c80ae2d3bdd1709f7ef8b6ece4d1abb109b9

View file

@ -0,0 +1,19 @@
diff --exclude-from=/home/dang/.scripts/diffrc -up -ruN GConf-2.23.2.old/gconf/gconftool.c GConf-2.23.2/gconf/gconftool.c
--- GConf-2.23.2.old/gconf/gconftool.c 2008-06-28 05:27:33.000000000 -0400
+++ GConf-2.23.2/gconf/gconftool.c 2008-09-23 10:20:00.000000000 -0400
@@ -856,6 +856,7 @@ main (int argc, char** argv)
{
g_print (_("GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL is set, not installing schemas\n"));
makefile_install_mode = FALSE;
+ return 0;
}
if (makefile_uninstall_mode &&
@@ -863,6 +864,7 @@ main (int argc, char** argv)
{
g_print (_("GCONF_DISABLE_MAKEFILE_SCHEMA_UNINSTALL is set, not uninstalling schemas\n"));
makefile_uninstall_mode = FALSE;
+ return 0;
}
if (makefile_install_mode || makefile_uninstall_mode)

View file

@ -0,0 +1,18 @@
From: Romain Perier <mrpouet@gentoo.org>
Date: Wed, 4 Nov 2009 11:58:25 +0100
Subject: Do not segfault when entry is NULL
---
gconf/gconf-value.c | 1 +
1 files changed, 1 insertions(+), 0 deletions(-)
--- a/gconf/gconf-value.c
+++ b/gconf/gconf-value.c
@@ -1609,6 +1609,7 @@ void
gconf_entry_set_value (GConfEntry *entry,
const GConfValue *val)
{
+ g_return_if_fail (entry != NULL);
gconf_entry_set_value_nocopy (entry,
val ? gconf_value_copy (val) : NULL);
}

View file

@ -0,0 +1,41 @@
From 405f865c07261a95c8c9a09a84ab679c6dd0a330 Mon Sep 17 00:00:00 2001
From: Colin Walters <walters@verbum.org>
Date: Thu, 24 Oct 2013 16:27:24 -0400
Subject: gsettings-data-convert: Warn (and fix) invalid schema paths
See https://bugzilla.gnome.org/show_bug.cgi?id=704802
https://bugzilla.gnome.org/show_bug.cgi?id=710836
diff --git a/gsettings/gsettings-data-convert.c b/gsettings/gsettings-data-convert.c
index 9b2d1d0..160ed41 100644
--- a/gsettings/gsettings-data-convert.c
+++ b/gsettings/gsettings-data-convert.c
@@ -182,7 +182,23 @@ handle_file (const gchar *filename)
}
if (schema_path[1] != NULL)
- settings = g_settings_new_with_path (schema_path[0], schema_path[1]);
+ {
+ char *compat_path_alloced = NULL;
+ char *compat_path;
+ /* Work around broken .convert files:
+ https://bugzilla.gnome.org/show_bug.cgi?id=704802
+ */
+ if (!g_str_has_suffix (schema_path[1], "/"))
+ {
+ g_warning ("Schema file '%s' has missing trailing / in '%s'",
+ filename, schema_path[1]);
+ compat_path = compat_path_alloced = g_strconcat (schema_path[1], "/", NULL);
+ }
+ else
+ compat_path = schema_path[1];
+ settings = g_settings_new_with_path (schema_path[0], compat_path);
+ g_free (compat_path_alloced);
+ }
else
settings = g_settings_new (schema_path[0]);
--
cgit v0.10.1

View file

@ -0,0 +1,45 @@
From 98ff7acca7595f508b094506195aeffaf2e8b74c Mon Sep 17 00:00:00 2001
From: Stefan Sauer <ensonic@users.sf.net>
Date: Wed, 23 Jan 2013 08:11:18 +0100
Subject: mconvert: enable recursive scheme lookup and fix a crasher
The recursive scheme lookup is needed to scan the whole settings path. The crash
would happen in the case of a misconfiguration (e.g. building gconf from source
and running uninstalled while the configure settings don't match the one used to
create the installed package).
diff --git a/gsettings/gsettings-data-convert.c b/gsettings/gsettings-data-convert.c
index a8af942..9b2d1d0 100644
--- a/gsettings/gsettings-data-convert.c
+++ b/gsettings/gsettings-data-convert.c
@@ -22,6 +22,7 @@
#include <string.h>
#include <sys/types.h>
#include <sys/stat.h>
+#include <stdlib.h>
#include <unistd.h>
#include <errno.h>
@@ -90,6 +91,10 @@ get_writable_client (void)
GSList *addresses;
addresses = get_writable_source_path ();
+ if (!addresses) {
+ g_printf("No writable gconf locations found\n");
+ exit (1);
+ }
engine = gconf_engine_get_local_for_addresses (addresses, NULL);
gconf_address_list_free (addresses);
@@ -155,7 +160,7 @@ handle_file (const gchar *filename)
schema_path = g_strsplit (groups[i], ":", 2);
- schema = g_settings_schema_source_lookup (source, schema_path[0], FALSE);
+ schema = g_settings_schema_source_lookup (source, schema_path[0], TRUE);
if (schema == NULL)
{
if (verbose)
--
cgit v0.10.1

View file

@ -0,0 +1,164 @@
From dbd4f1bc1992c2942538980e76a50c8b8a758d70 Mon Sep 17 00:00:00 2001
From: Takao Fujiwara <tfujiwar@redhat.com>
Date: Fri, 11 Dec 2015 18:29:49 +0900
Subject: [PATCH] gsettings-schema-convert: Support python3
https://bugzilla.gnome.org/show_bug.cgi?id=759334
---
gsettings/gsettings-schema-convert | 43 ++++++++++++++++++++------------------
1 file changed, 23 insertions(+), 20 deletions(-)
diff --git a/gsettings/gsettings-schema-convert b/gsettings/gsettings-schema-convert
index 913cc83..6ccf8c5 100755
--- a/gsettings/gsettings-schema-convert
+++ b/gsettings/gsettings-schema-convert
@@ -25,6 +25,9 @@
# TODO: we don't support migrating a pair from a gconf schema. It has yet to be
# seen in real-world usage, though.
+from __future__ import print_function
+
+import codecs
import os
import sys
@@ -398,7 +401,7 @@ class SimpleSchemaParser:
def _word_to_token(self, word):
lower = word.lower()
- if lower and lower in self.allowed_tokens.keys():
+ if lower and lower in list(self.allowed_tokens.keys()):
return lower
raise GSettingsSchemaConvertException('\'%s\' is not a valid token.' % lower)
@@ -594,7 +597,7 @@ class SimpleSchemaParser:
self.object_stack.append(new_object)
def parse(self):
- f = open(self.file, 'r')
+ f = codecs.open(self.file, 'r', encoding='utf-8')
lines = [ line[:-1] for line in f.readlines() ]
f.close()
@@ -603,7 +606,7 @@ class SimpleSchemaParser:
for line in lines:
current_line_nb += 1
self.parse_line(line)
- except GSettingsSchemaConvertException, e:
+ except GSettingsSchemaConvertException as e:
raise GSettingsSchemaConvertException('%s:%s: %s' % (os.path.basename(self.file), current_line_nb, e))
return self.root
@@ -711,7 +714,7 @@ class XMLSchemaParser:
schema = self._parse_schema(schema_node)
for (child_schema, child_name) in schema._children:
- if parent.has_key(child_schema):
+ if child_schema in parent:
raise GSettingsSchemaConvertException('Child \'%s\' is declared by two different schemas: \'%s\' and \'%s\'.' % (child_schema, parent[child_schema], schema.id))
parent[child_schema] = schema
@@ -719,7 +722,7 @@ class XMLSchemaParser:
# now let's move all schemas where they should leave
for schema in schemas:
- if parent.has_key(schema.id):
+ if schema.id in parent:
parent_schema = parent[schema.id]
# check that the paths of parent and child are supported by
@@ -1054,31 +1057,31 @@ def main(args):
(options, args) = parser.parse_args()
if len(args) < 1:
- print >> sys.stderr, 'Need a filename to work on.'
+ print('Need a filename to work on.', file=sys.stderr)
return 1
elif len(args) > 1:
- print >> sys.stderr, 'Too many arguments.'
+ print('Too many arguments.', file=sys.stderr)
return 1
if options.simple and options.xml:
- print >> sys.stderr, 'Too many output formats requested.'
+ print('Too many output formats requested.', file=sys.stderr)
return 1
if not options.gconf and options.gettext_domain:
- print >> sys.stderr, 'Default gettext domain can only be specified when converting a gconf schema.'
+ print('Default gettext domain can only be specified when converting a gconf schema.', file=sys.stderr)
return 1
if not options.gconf and options.schema_id:
- print >> sys.stderr, 'Default schema ID can only be specified when converting a gconf schema.'
+ print('Default schema ID can only be specified when converting a gconf schema.', file=sys.stderr)
return 1
if not options.gconf and options.keep_underscores:
- print >> sys.stderr, 'The --keep-underscores option can only be specified when converting a gconf schema.'
+ print('The --keep-underscores option can only be specified when converting a gconf schema.', file=sys.stderr)
return 1
argfile = os.path.expanduser(args[0])
if not os.path.exists(argfile):
- print >> sys.stderr, '\'%s\' does not exist.' % argfile
+ print('\'%s\' does not exist.' % argfile, file=sys.stderr)
return 1
if options.output:
@@ -1095,7 +1098,7 @@ def main(args):
try:
parser = GConfSchemaParser(argfile, options.gettext_domain, options.schema_id, options.keep_underscores)
schema_root = parser.parse()
- except SyntaxError, e:
+ except SyntaxError as e:
raise GSettingsSchemaConvertException('\'%s\' does not look like a valid gconf schema file: %s' % (argfile, e))
else:
# autodetect if file is XML or not
@@ -1104,7 +1107,7 @@ def main(args):
schema_root = parser.parse()
if not options.simple and not options.xml:
options.simple = True
- except SyntaxError, e:
+ except SyntaxError as e:
parser = SimpleSchemaParser(argfile)
schema_root = parser.parse()
if not options.simple and not options.xml:
@@ -1113,10 +1116,10 @@ def main(args):
if options.xml:
node = schema_root.get_xml_node()
try:
- output = ET.tostring(node, pretty_print = True)
+ output = ET.tostring(node, pretty_print = True, encoding="unicode")
except TypeError:
# pretty_print only works with lxml
- output = ET.tostring(node)
+ output = ET.tostring(node, encoding="unicode")
else:
output = schema_root.get_simple_string()
@@ -1124,17 +1127,17 @@ def main(args):
sys.stdout.write(output)
else:
try:
- fout = open(options.output, 'w')
+ fout = codecs.open(options.output, 'w', encoding='utf-8')
fout.write(output)
fout.close()
- except GSettingsSchemaConvertException, e:
+ except GSettingsSchemaConvertException as e:
fout.close()
if os.path.exists(options.output):
os.unlink(options.output)
raise e
- except GSettingsSchemaConvertException, e:
- print >> sys.stderr, '%s' % e
+ except GSettingsSchemaConvertException as e:
+ print('%s' % e, file=sys.stderr)
return 1
return 0
--
2.4.3

View file

@ -0,0 +1,83 @@
From b0895e1998ebc83ab030ec0f17c0685439f5b404 Mon Sep 17 00:00:00 2001
From: Ray Strode <rstrode@redhat.com>
Date: Mon, 15 Apr 2013 09:57:34 -0400
Subject: dbus: Don't spew to console when unable to connect to dbus daemon
Instead pass the error up for the caller to decide what to do.
This prevent untrappable warning messages from showing up at the
console if gconftool --makefile-install-rule is called.
diff --git a/gconf/gconf-dbus.c b/gconf/gconf-dbus.c
index 5610fcf..048e3ea 100644
--- a/gconf/gconf-dbus.c
+++ b/gconf/gconf-dbus.c
@@ -105,7 +105,7 @@ static GHashTable *engines_by_db = NULL;
static GHashTable *engines_by_address = NULL;
static gboolean dbus_disconnected = FALSE;
-static gboolean ensure_dbus_connection (void);
+static gboolean ensure_dbus_connection (GError **error);
static gboolean ensure_service (gboolean start_if_not_found,
GError **err);
static gboolean ensure_database (GConfEngine *conf,
@@ -383,7 +383,7 @@ gconf_engine_detach (GConfEngine *conf)
}
static gboolean
-ensure_dbus_connection (void)
+ensure_dbus_connection (GError **err)
{
DBusError error;
@@ -392,7 +392,9 @@ ensure_dbus_connection (void)
if (dbus_disconnected)
{
- g_warning ("The connection to DBus was broken. Can't reinitialize it.");
+ g_set_error (err, GCONF_ERROR,
+ GCONF_ERROR_NO_SERVER,
+ "The connection to DBus was broken. Can't reinitialize it.");
return FALSE;
}
@@ -402,7 +404,10 @@ ensure_dbus_connection (void)
if (!global_conn)
{
- g_warning ("Client failed to connect to the D-BUS daemon:\n%s", error.message);
+ g_set_error (err, GCONF_ERROR,
+ GCONF_ERROR_NO_SERVER,
+ "Client failed to connect to the D-BUS daemon:\n%s",
+ error.message);
dbus_error_free (&error);
return FALSE;
@@ -431,13 +436,8 @@ ensure_service (gboolean start_if_not_found,
if (global_conn == NULL)
{
- if (!ensure_dbus_connection ())
- {
- g_set_error (err, GCONF_ERROR,
- GCONF_ERROR_NO_SERVER,
- _("No D-BUS daemon running\n"));
- return FALSE;
- }
+ if (!ensure_dbus_connection (err))
+ return FALSE;
g_assert (global_conn != NULL);
}
@@ -2512,7 +2512,7 @@ gconf_ping_daemon (void)
{
if (global_conn == NULL)
{
- if (!ensure_dbus_connection ())
+ if (!ensure_dbus_connection (NULL))
{
return FALSE;
}
--
cgit v0.10.1

View file

@ -0,0 +1,148 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
GNOME_ORG_MODULE="GConf"
PYTHON_COMPAT=( python3_{8..11} )
PYTHON_REQ_USE="xml(+)"
inherit gnome2 multilib-minimal python-single-r1
DESCRIPTION="GNOME configuration system and daemon"
HOMEPAGE="https://projects.gnome.org/gconf/"
LICENSE="LGPL-2+"
SLOT="2"
KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~mips ppc ppc64 ~riscv sparc x86 ~x86-linux"
IUSE="debug +introspection ldap policykit"
RDEPEND="
${PYTHON_DEPS}
>=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
>=dev-libs/dbus-glib-0.100.2:=[${MULTILIB_USEDEP}]
>=sys-apps/dbus-1.6.18-r1:=[${MULTILIB_USEDEP}]
>=dev-libs/libxml2-2.9.1-r4:2[${MULTILIB_USEDEP}]
introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
ldap? ( >=net-nds/openldap-2.4.38-r1:=[${MULTILIB_USEDEP}] )
policykit? ( sys-auth/polkit:= )
"
DEPEND="${RDEPEND}
dev-libs/libxslt
dev-util/glib-utils
dev-util/gtk-doc-am
>=dev-util/intltool-0.35
virtual/pkgconfig
"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
pkg_setup() {
kill_gconf
python-single-r1_pkg_setup
}
src_prepare() {
# Do not start gconfd when installing schemas, fix bug #238276, upstream #631983
eapply "${FILESDIR}/${PN}-2.24.0-no-gconfd.patch"
# Do not crash in gconf_entry_set_value() when entry pointer is NULL, upstream #631985
eapply "${FILESDIR}/${PN}-2.28.0-entry-set-value-sigsegv.patch"
# From 'master'
# mconvert: enable recursive scheme lookup and fix a crasher
eapply "${FILESDIR}/${P}-mconvert-crasher.patch"
# dbus: Don't spew to console when unable to connect to dbus daemon
eapply "${FILESDIR}/${P}-spew-console-error.patch"
# gsettings-data-convert: Warn (and fix) invalid schema paths
eapply "${FILESDIR}/${P}-gsettings-data-convert-paths.patch"
# gsettings-data-convert: Migrate from Python 2 to 3.
eapply "${FILESDIR}/${P}-python3.patch"
gnome2_src_prepare
}
multilib_src_configure() {
ECONF_SOURCE=${S} \
gnome2_src_configure \
--disable-static \
--enable-gsettings-backend \
--with-gtk=3.0 \
--disable-orbit \
$(use_enable debug) \
$(multilib_native_use_enable introspection) \
$(use_with ldap openldap) \
$(multilib_native_use_enable policykit defaults-service)
if multilib_is_native_abi; then
ln -s "${S}"/doc/gconf/html doc/gconf/html || die
fi
}
multilib_src_install() {
gnome2_src_install
}
multilib_src_install_all() {
python_fix_shebang "${ED}"/usr/bin/gsettings-schema-convert
keepdir /etc/gconf/gconf.xml.mandatory
keepdir /etc/gconf/gconf.xml.defaults
# Make sure this directory exists, bug #268070, upstream #572027
keepdir /etc/gconf/gconf.xml.system
echo "CONFIG_PROTECT_MASK=\"/etc/gconf\"" > 50gconf
echo 'GSETTINGS_BACKEND="gconf"' >> 50gconf
doenvd 50gconf
dodir /root/.gconfd
}
pkg_preinst() {
kill_gconf
gnome2_pkg_preinst
}
pkg_postinst() {
kill_gconf
gnome2_pkg_postinst
multilib_pkg_postinst() {
gnome2_giomodule_cache_update \
|| die "Update GIO modules cache failed (for ${ABI})"
}
multilib_foreach_abi multilib_pkg_postinst
# change the permissions to avoid some gconf bugs
einfo "changing permissions for gconf dirs"
find "${EPREFIX}"/etc/gconf/ -type d -exec chmod ugo+rx "{}" \;
einfo "changing permissions for gconf files"
find "${EPREFIX}"/etc/gconf/ -type f -exec chmod ugo+r "{}" \;
}
pkg_postrm() {
gnome2_pkg_postrm
multilib_pkg_postrm() {
gnome2_giomodule_cache_update \
|| die "Update GIO modules cache failed (for ${ABI})"
}
multilib_foreach_abi multilib_pkg_postrm
}
kill_gconf() {
# Avoid harmless error message. See bug #523868.
mkdir -p "${HOME}"/.config || die
# This function will kill all running gconfd-2 that could be causing troubles
if [ -x "${EPREFIX}"/usr/bin/gconftool-2 ]
then
"${EPREFIX}"/usr/bin/gconftool-2 --shutdown
fi
return 0
}

View file

@ -0,0 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>gnome@gentoo.org</email>
<name>Gentoo GNOME Desktop</name>
</maintainer>
<use>
<flag name="ldap">Build backend which enables default mail accounts, addressbooks and calendars for Evolution to be configured using each user's LDAP entry."</flag>
</use>
<upstream>
<remote-id type="gnome-gitlab">Archive/gconf</remote-id>
</upstream>
</pkgmetadata>

View file

@ -0,0 +1,3 @@
DIST gnome-mime-data-2.18.0.tar.bz2 607012 BLAKE2B 6653e11f04f94035e7bf7d12413870b6e425bb32c50cd0776fae93be05eaea6eb4116f8d068e86c39fca9a3f86148934357d5a1c538a7deaae117151b8f1e466 SHA512 132996786254799341eeaa7894749cf4a95e391e31d985b1527b2f3dfeeeb01e7cc000753fc21d559db07fcc92018f4839f170eb149cb457fe06058ad3d986d5
EBUILD gnome-mime-data-2.18.0-r1.ebuild 551 BLAKE2B d619182a20600b2333de6faa8e37edda225ceac3734d227a3fecc580b21923f0f7af725b977231fbeaf20d7e80a19e307f7c84328d478838229a71ace077bf48 SHA512 54c1a3b0c691183dc4a45987a8815adbafae1392a0b4bd231159f660fa9cdecbd5e5fce6a8361f1a5f9797b4aea5de653dfc7737788c6ec088e170a429721f28
MISC metadata.xml 250 BLAKE2B 8f7f0fe023d43e380e7861e897e6afcb5de4baefb42ea9c65a57dfc0d204c6f787a99295141832e732ebb08be218da56ba77e2dd9639e4e3aabf718ce4db1d0c SHA512 2684e772dd6d83e4b49f08f2ba22d8a0a753e7b46863489eff1b5d1f2f147ad80ffd93245ca405ac4c747249bc1b754454ec9865fe16da70f9b257051e105fd8

View file

@ -0,0 +1,24 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
GNOME_TARBALL_SUFFIX="bz2"
inherit gnome2
DESCRIPTION="MIME data for Gnome"
HOMEPAGE="https://www.gnome.org/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
BDEPEND="
virtual/pkgconfig
>=dev-util/intltool-0.35"
src_prepare() {
intltoolize --force || die "intltoolize failed"
gnome2_src_prepare
}

View file

@ -0,0 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>gnome@gentoo.org</email>
<name>Gentoo GNOME Desktop</name>
</maintainer>
</pkgmetadata>

View file

@ -12,5 +12,5 @@ AUX gnome-vfs-2.24.4-gnutls34.patch 1624 BLAKE2B 9b29ee3e95ad79f31a9d4adc494aa6b
AUX gnome-vfs-2.24.4-home_dir_fakeroot.patch 4996 BLAKE2B 9883ef67221c053df5ad2d3f70e3f7c3f1916660cb35dd82a0dc52008ffd1a780f685a7af82a2dda1ec25aae5d1f024322b3a8c20bd8d48227405d0c1c357b48 SHA512 dcad32f15afaa7677c6d10672c06c6d635a17d2bb686883c94f42bfc4f9fc6c525c4f097c3af718020fd224e06bba0d0a4ec68cde431545e9fe4a2c65320a48f
AUX gnome-vfs-2.24.4-openssl-1.1.patch 873 BLAKE2B 3dbd2cc42d191468de567d4a10bbb417e73e1e9deb89c0d1f4348a73066dffcdd0cf80ca8476ccb6adad35e3354dd54de2c5b5ab0bfc62706f3c3086440eec10 SHA512 20bd3959b3e240498a502ba94491fed3e71966a1dffc9d91b3c718f0cc6d6d294b4039810d408242296fef471745cb3c1b64a18df33e9b147d2ba151716f3edc
DIST gnome-vfs-2.24.4.tar.bz2 1890370 BLAKE2B 696c8ce479de5a15660c9cc79eeb1abb6d69716f68558c7f791a3a44a7f1e9d09d9bc9adcca11dabd745f36a70222817b68888f3c56839add737b802aba0e7ac SHA512 db4e49f5356647667c4d40c7ce5c299c934cb41069b2086fb89c4e87b2202b5009616d65c1dafeb93e37033a5a68965342c2b18d87b8a3265c4347dec5128581
EBUILD gnome-vfs-2.24.4-r5.ebuild 4233 BLAKE2B f36fae5afb91314d72507c09b47feaf87c8c3f72779f67a0a2398a92d6855aef420209872fa3866a7efc645e826e1edab66c9abea256d7f9402ecc21fdbdf394 SHA512 f0efe6a45d370e38417194c568e335de0a09f69208b513243dfd3276f67a3eb64efb36bfe6e02eed4880dd33a1d557e1edbf14c6e78398fd720353c1ab96e096
EBUILD gnome-vfs-2.24.4-r6.ebuild 4226 BLAKE2B a9e3b38addf035e2faf51b2d9cda90e9d96de481da510bb1be032fef8894d74420f457fb17539faf12ecf6608e2405883be00546921d75a018ac9b865c02a707 SHA512 9e0aa691f6779dc2746d02cb2b249c093551127e32299be5a9f7c626d402c9147362c72dd917bfbbe6eee3df404fdaddba0a884cbf2be03ca18ebe33b11c9272
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506

View file

@ -1,11 +1,11 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
EAPI=8
GNOME_TARBALL_SUFFIX="bz2"
GNOME2_LA_PUNT="yes"
inherit autotools eutils gnome2 multilib-minimal virtualx
inherit autotools gnome2 multilib-minimal virtualx
DESCRIPTION="Gnome Virtual Filesystem"
HOMEPAGE="https://www.gnome.org/"