56 lines
2 KiB
Diff
56 lines
2 KiB
Diff
diff -uri redis.orig/debian/changelog redis_5.0.3-4/debian/changelog
|
|
--- redis.orig/debian/changelog 2021-02-25 17:46:45.000000000 +0000
|
|
+++ redis_5.0.3-4/debian/changelog 2021-08-31 06:39:39.010697241 +0000
|
|
@@ -1,3 +1,10 @@
|
|
+redis (5:5.0.3-4+deb10u4) buster; urgency=medium
|
|
+
|
|
+ * TLS support.
|
|
+ (Closes: #951255)
|
|
+
|
|
+ -- Sandino Araico Sanchez <sandino@sandino.net> Tue, 31 Aug 2021 01:40:45 -0500
|
|
+
|
|
redis (5:5.0.3-4+deb10u3) buster; urgency=medium
|
|
|
|
* CVE-2021-21309: Fix a series of integer overflow issues on 32-bit systems.
|
|
diff -uri redis.orig/debian/control redis_5.0.3-4/debian/control
|
|
--- redis.orig/debian/control 2021-02-25 17:46:45.000000000 +0000
|
|
+++ redis_5.0.3-4/debian/control 2021-08-31 06:28:34.058345898 +0000
|
|
@@ -8,10 +8,12 @@
|
|
libhiredis-dev (>= 0.14.0),
|
|
libjemalloc-dev [linux-any],
|
|
liblua5.1-dev,
|
|
+ libssl-dev,
|
|
lua-bitop-dev,
|
|
lua-cjson-dev,
|
|
procps <!nocheck>,
|
|
tcl <!nocheck>,
|
|
+ tcl-tls <!nocheck>,
|
|
Standards-Version: 4.3.0
|
|
Homepage: https://redis.io/
|
|
Vcs-Git: https://salsa.debian.org/lamby/pkg-redis.git
|
|
diff -uri redis.orig/debian/rules redis_5.0.3-4/debian/rules
|
|
--- redis.orig/debian/rules 2021-02-25 17:46:45.000000000 +0000
|
|
+++ redis_5.0.3-4/debian/rules 2021-08-31 06:31:35.015530109 +0000
|
|
@@ -17,6 +17,7 @@
|
|
export CFLAGS CPPFLAGS LDFLAGS
|
|
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
|
|
export DEB_LDFLAGS_MAINT_APPEND = -Wl,-no-as-needed -ldl -latomic $(LUA_LDFLAGS)
|
|
+export BUILD_TLS=yes
|
|
|
|
ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
|
|
NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
|
|
@@ -48,9 +49,11 @@
|
|
|
|
override_dh_auto_test:
|
|
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
|
|
- # Avoid race conditions in upstream testsuite.
|
|
- ./runtest --clients 1 || true
|
|
- ./runtest-cluster || true
|
|
+ # Generate a root CA and server certificate for testing
|
|
+ ./utils/gen-test-certs.sh
|
|
+ # Avoid race conditions in upstream testsuite
|
|
+ ./runtest --clients 1 --tls || true
|
|
+ ./runtest-cluster --tls || true
|
|
./runtest-sentinel || true
|
|
endif
|
|
|