4ac8c8ee28
rational: building for release takes a lot of time and we neither package, nor run (most of) these unit tests when we make packages. CI runs all of these tests before merging PRs, so risk is low, if we do not run the few build-time unit tests when we package. make -j12 --enable-tests (default): 3m 18s --disable-test: 1m 9s 3x faster... Signed-off-by: Andras Timar <andras.timar@collabora.com> Change-Id: I4edd98af55748432e30c65c4c910e72c0221272a
21 lines
569 B
Makefile
21 lines
569 B
Makefile
#!/usr/bin/make -f
|
|
|
|
# see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/*
|
|
DPKG_EXPORT_BUILDFLAGS = 1
|
|
|
|
include /usr/share/dpkg/default.mk
|
|
|
|
CONFFLAGS = --enable-silent-rules --prefix=/usr --localstatedir=/var --sysconfdir=/etc --with-lokit-path=`pwd`/bundled/include --disable-setcap --disable-tests $(CONFIG_OPTIONS)
|
|
|
|
# main packaging script based on dh7 syntax
|
|
%:
|
|
dh $@ --with=systemd --parallel
|
|
|
|
override_dh_auto_configure:
|
|
./configure $(CONFFLAGS)
|
|
|
|
override_dh_auto_test:
|
|
# do not test
|
|
|
|
override_dh_installinit:
|
|
# no init.d scripts here, assume systemd
|